Current status of the Ning Platform is always available on the Ning Status Blog.

Forum

This is becoming a real pain up the bum, custom code is being blocked from running now by Chrome, IE and Firefox. Some code runs and some does not. If you have let's say a page which is viewable to everyone but only members can add to it then custom code on that page does not run, sign in and it runs no problem. It's the same with normal pages as well.

This is causing a lot of problems when trying to design a site as you have to check if it looks the same for non members. I had to resort to using a lot of CSS and not use some code I would have prefered to.

Here is a simple example, all the code is to do is move the byline up to the avatar. Not really intense code just one line. Using Chrome examples but it's the same for the others.

CHROME SIGNED OUT

NOW CHROME SIGNED IN

And here is what is getting added to custom code by the browsers to stop it running

Now not sure whether this has to do with the new security been added by them but it seems that way as it always use to work before.

Anyone else having these issues, or have you not noticed ? Best check your sites to see if they are doing the same thing.

It's a real pain and may just have to resort to keeping all the pages viewable to members only so the code runs and just have one information page for non members to see. Nightmare!

grrr John :-(

You need to be a member of Ning Creators Social Network to add comments!

Join Ning Creators Social Network

Email me when people reply –

Replies

  • Just found a way to get around this, add your code to notepad and save them as js files. Then add them to file manager and link to them in custom code. This seems to bypass the custom code loading issue. Tried it and now the code runs.

  • John maybe it has something to do with the code?  idk because I have custom code that puts the photo title above the photo and it's working in both signed in and signed out.

    Thinking further, how would our meta and site map even be read if ignored when signed out?  It makes no sense to me (but that's nothing new) but they're in Custom Code in 3.0

    • Thanks Kos and yes some code does run as normal but it's certain types that seem to be not. I have started removing bits of code to try and see if it's one of my blocks but I really do not have very much in there at all now. hmm will get to the bottom of it I hope.

      May change themes to see if that helps but it will mean a bit of faffing around to get it looking like my site as it is now.

  • Hi John,

    Could you please send me the code that you are using so we could perform the proper testing?

    If you don't wish to share it with everybody you can send it to me via private message.

    Best regards,

    Ning Team.

    • Thanks for the reply Kyryl, I will post it once I just do a little more testing by removing all my custom code and add it back in one block at a time to try and pin point it. Never had any issues before with code being blocked so this is something new.

      John :-)

    • Ok here is what I came up with after removing all the code then adding it back in one block at a time and it seems if it's anything to do with the actvity feed it get's blocked, but here is the thing if you sign in it works, if you add it to the file manager and link to it in code then it works whether signed in or not. So the code is working fine but it's getting blocked by Chrome and IE.

      I will just include on part of the code which is to remove the crop of the video images ( by the way why do why have to have these and the photos cropped so small ? If they where not so small we would not have to keep writing code to remove the crops ) this code was by Sweet Potatoe shared as a tip for removing the crop of images which I changed just for the videos.

      <script>
      // Remove crop from activity video images
      x$(document).ready(function() {
      x$('.activityFeed').ajaxSuccess(function() {
      x$('.feedEvent-createVideoLike .activityFeed-content.media-frame .activityFeed-image img, .feedEvent-createVideoComment .activityFeed-content.media-frame .media-img img,.feedEvent-createVideoRollup .activityFeed-content.media-frame .media-img img').each(function() {
          var videoSize_Attr = x$(this).attr('src');
          x$(this).attr('src', videoSize_Attr.replace(/\?width=\d+\&height=\d+\&crop=\d+\%\d+\A\d+/, ''));
      x$('.feedEvent-createVideoLike .activityFeed-content.media-frame .activityFeed-image img, .feedEvent-createVideoComment .activityFeed-content.media-frame .media-img img,.feedEvent-createVideoRollup .activityFeed-content.media-frame .media-img img').fadeIn();
      });
      });
      });
      </script>

      Now here is a video of me showing the image still small when signed out then when I sign in it works as you can see.

      Looking forward to your reply on this one,

      Thanks Kyryl

      CodeNot Loading - YouTube
      • Hi John,

        Thanks for sharing the code with me so I could run the test on my test network.

        And as I see the code is working like it should when I'm logged in and when I'm not (for the proper testing I have used two different pcs). So it seems there is something wrong with the network itself, so I'll ask QA department to take a look into this, probably they would be able to see what is the problem.

        I'll inform you about their conclusion.

        Regards,

        Ning Team.

        CodeNot Loading - YouTube
  • I think I found the issue with this. On my homepage I had two html content box's, one was for non members to see and the other for members to see. I did not add any code for this and just used Nings option for display when adding the box's. So I removed those two box's and everything works now as it should ( so far! ). Not had these issues with these before so will have to do some testing just to make sure in case it is these that cuase and not use that option for display if this is the case.

    Kyryl it might be worth adding some content box's on your site set as mentioned above to see if this does the same on your test site.

    • Hi John,

      Just checked the code with two html boxes on the main page and the script working properly. Have you had anything special in that html boxes? In my case, I have tested the code with the plain text in html boxes, with the hyperlinks and iframes as well. As usual, I have run the test in both Chrome and FireFox.

      Regards,

      Ning Team.

      • Thanks for the reply Kyryl and testing this out. No nothing special within them just a list of links and images. Will just have to keep an eye on it to see what could be causing it.

This reply was deleted.

Search the Creators Network

Latest Activity

Manuel Adame Jimenez replied to Kyryl_Ning_Support's discussion Our Efforts - Your Feedback
"Patience ... with the look in the moment that comes ... thanks
♤♡♧"
24 minutes ago
Bizz ( John ) replied to Naveen Jain's discussion How can I disable Ning Search in 3.0
"Mike can't seem to find a way yet to block the search for private groups but here is a way you can…"
40 minutes ago
⚡JFarrow⌁ replied to Bizz ( John )'s discussion Photo Albums and Video Albums ( the one thing missing that could really improve things )
"Yes I would like this"
1 hour ago
Janice D Carter replied to Kyryl_Ning_Support's discussion Network not launched yet issue
"Still no chat and no communication about when.  I can almost tolerate an issue if I am being told w…"
1 hour ago
Rosario Sarno (Saro) replied to Kyryl_Ning_Support's discussion Network not launched yet issue
"On my site, chat is no longer working, you do not see who's online
http://www.fotografiapuntodincon&hellip;"
1 hour ago
Fran replied to Marcelo Rodrigues's discussion Chat problem
"My chat,  down too :S"
2 hours ago
Bizz ( John ) replied to Alex's discussion NING 3 Groups on Home Page
"Your welcome Alex :-)"
3 hours ago
⚡JFarrow⌁ replied to Fabricio Giugni's discussion Create a member Pro. What can he do that others can't?
"You could offer access to a group or set of pages that other members can't see..."
4 hours ago
Kevin Acosta replied to Kyryl_Ning_Support's discussion Chat Feature Update on Ning 3.0 is ready!
"FYI - some programming glitch is also affecting the old Ning 2.0 Pro sites . . . same "blank" regis…"
6 hours ago
Kevin Acosta replied to Marcelo Rodrigues's discussion Chat problem
"Apparently having the same issue here, including the timing as reported by site members while I was…"
6 hours ago
Kevin Acosta replied to Kyryl_Ning_Support's discussion Network not launched yet issue
"@ Kyryl - - thanks for these updates.  I was out of pocket traveling the past week, and several mem…"
6 hours ago
Tyler Durbin replied to Marcelo Rodrigues's discussion Chat problem
"My chat has been down for 2 days!  They are saying that it is a bug.  Ugggg...."
6 hours ago
Alex replied to Alex's discussion NING 3 Groups on Home Page
"Thank you John... works a treat.
Much obliged!
Alex"
6 hours ago
Manuel Adame Jimenez replied to Kyryl_Ning_Support's discussion Chat Feature Update on Ning 3.0 is ready!
"Patience Kos
{[°III ♤ ♡ ♧ III°]}"
6 hours ago
Bizz ( John ) replied to Naveen Jain's discussion How can I disable Ning Search in 3.0
"Not sure, but will have to take a look to see if it's possible."
7 hours ago
Bizz ( John ) replied to Alex's discussion NING 3 Groups on Home Page
"I would write this with this code below as it would keep the groups a nice size and not to small mu…"
7 hours ago
Ning via Facebook

#Ning #radio #online Tune in to the radio, find your playmates - and have fun on…

Mike Collins replied to Naveen Jain's discussion How can I disable Ning Search in 3.0
"John is there anyway of excluding the search in private groups through code?"
8 hours ago
Naveen Jain replied to Naveen Jain's discussion How can I disable Ning Search in 3.0
"This worked. Thanks"
8 hours ago
Naveen Jain replied to Naveen Jain's discussion How can I disable Ning Search in 3.0
"culytics.com"
8 hours ago
More…