For the last couple of days I have been browsing the discussions here on Ning creators. Just checking in to see if I could help on any that were not solved or maybe add to them if I could.

I noticed many request to move the site activity to it's own page, but I could not find any discussions where someone replied with a solution. So this is what I worked on today.

View live demo:

Instructions:

First, you will need to set your activity module preferences IE... text count, number of items to show and so on, we will be hiding it later with CSS.

**IMPORTANT:

Move the activity module to the right column of your Ning Powered Website. This tip will not work, if the activity module is not in the right hand column. Thank you  Nyein!

Next:

We need to create a new page. You can choose to show this page to everyone or signed in members only. Give the page a title, click the HTML tab in the page editor and paste the code below into the text box area.
 

<div id="cafp"><h2>TZN Latest Site Activity</h2></div>



Now scroll to the bottom of the page and tick the box that says "Manage title and meta tags manually (advanced)". Now copy the code below and past it in the the custom box area at the bottom of the page.
 

<style>
.xg_widget_page_page_show .xj_sidebar_content .xg_module_activity {display: none;}
#cafp h2 {font-size:20px;}
#xg_network_activity .xg_module_head {display:none;}
</style>

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.js"></script>

<script>

$(document).ready(function(){

$("#xg_network_activity")
.appendTo("#cafp");

});

</script>




Now click on "Save Page". You will have to refresh the page for it to all start working.

Last Words:

If this does not go off without a hitch, please don't get upset. I may have left something out. Reply below if you need help.

This Tip Last updated on: 4-6-2012

****Thank you  Nyein for this fix. The "Activity Module" must be in placed in the right hand column of your Ning powered website in order for this tip to work.


Updated 4-7-2012 Thank you Dr. Trocar!

This works perfectly. But you MUST not tick the "Use full page width (hide sidebar)"  Again, it will not function when this box is ticked.  Also as mentioned the Activity feed must  be in the uppermost portition of the right column, and directly below the username.  I had problems getting anything to show when I had this ticked.  No wonder, I finally tracked this burger down!  Thanks Anthony, you might want to amend your directions/instructions on this at the beginning of this thread to make sure no one misses this.  I appreciate it, you always have excellent tips. 

Thank you Michael Thompson

This tip only works for me when the activity feed is not only in the right column, but it also has to be in the top colored area so that it shows on all pages. So, the feed still shows on all the pages. 

Tags: activity feed, custom page, move activity feed

Views: 1306

Reply to This

Replies to This Discussion

Doc,

How did you get it to hide the feed on all of the other pages (besides the homepage)? 

I used this:

.xg_widget_main .xg_module_activity {display:none!important;}
.xg_widget_main .xg_module_activity .xg_module_head h2 {display:none!important;}

That hides it on the homepage but not on the rest of the site pages.

Instead of this:

.xg_widget_main .xg_module_activity {display:none!important;}
.xg_widget_main .xg_module_activity .xg_module_head h2 {display:none!important;}

Do this:

.xg_widget_main_index_index .xg_module_activity {display:inherit !important;}
.xg_widget_main_index_index .xg_module_activity .xg_module_head h2 {display:inherit !important;}

Add this new code to the advanced CSS area of your site, not to the custom box area on the page where you are shoing the activity feed.

If I misunderstood your question and you don't want it to show on the front page of your site, add the code below to hide it on your front page. Same thing about placement, paste the code in the advanced CSS area of your site and not on the page.

.xg_widget_main_index_index .xg_module_activity {display:none !important;}

Anthony,

I tried it but it didn't seem to work. 

Can you PM me your site URL?

You want to hide the activity module on your front page, right? 

Sounds great. I am very happy to hear you now have it live on your site and bug free. Have a great weekend!

I want to hide the activity feed on the front page AND on all other pages (except for my new activity feed page). The feed would not show up on my new page unless I put the front page feed at the TOP of the right column where it shows up on all other pages. It doesn't work further down in the right column, only at the top where it shows on all pages. 

At this time, I went back to this code to hide it on the homepage:

.xg_widget_main .xg_module_activity {display:none!important;}

That code works for the homepage but not the other pages. The second set of codes did not hide the activity feed on the homepage or the other pages:

.xg_widget_main_index_index .xg_module_activity {display:inherit !important;}
.xg_widget_main_index_index .xg_module_activity .xg_module_head h2 {display:inherit !important;}

My new Activity Feed page can be found on a subtab directly below the HOME tab. 

Here is my site url: http://www.standingstonenews.com

Click on the NEWS tab and you can see the feed on the other pages. 

Try this:

.xj_sidebar_content .xg_module_activity {display:none !important;}

It should hide it everywhere. If it works, make sure you check the activity page. Not sure if that is gonna hide it there as well.

You might want to check and make sure you don't have any code like the code above already in your advanced CSS area. If you are duplicating code, it will not work. 

It worked! Thanks Anthony. It is hidden from the right columns in pages, but still remains on my new activity feed page. Thanks very much!

@Michael Thompson

If it still shows on the activity page, make sure you are using the custom CSS  from the instructions above.

<style>
.xg_widget_page_page_show .xj_sidebar_content .xg_module_activity {display: none;}
#cafp h2 {font-size:20px;}
#xg_network_activity .xg_module_head {display:none;}
</style>


The code from above (.xg_widget_page_page_show .xj_sidebar_content .xg_module_activity) hides it on your activity page.

 

Hi Anthony,

your script is awesome! It's been a while I've been wondering whether it was possible to move some boxes from the Features Layout onto pages built from scratch. Thanks for sharing it with us :-)

However, I face a small problem: on the page where I've integrated your script, if I select "Use full page width (hide sidebar)", the script disappears! Does anyone have an idea why this is happening and above all, how to solve that problem?

Thanks for your help :-)

RSS

What's Up With Ning 3.0?

Click here to share your thoughts on what features we should develop next! - Survey will close Friday, 4/25

Projects that the Ning 3.0 Team is currently working on: 

Articles - a new way of organizing longer content pieces. Released 4/16.

Activity Feed Updates - options for more content in the activity feed.

Forum Notifications - ability for members to opt into receiving notifications of new discussions in forums. Released 4/9. 

APIs - The ability to create new members and content programatically.

For more information on what's next, visit the Product Roadmap

Latest Activity

Jelena replied to Riccardo Rossini's discussion 'Please Ning staff'
"Same as SE. That would be a problem with the Trademark name.."
1 hour ago
soaringeagle replied to Riccardo Rossini's discussion 'Please Ning staff'
"same on all sites its a bug"
1 hour ago
Jelena replied to Riccardo Rossini's discussion 'Please Ning staff'
"Hi Riccardo I see no navegation on your network"
1 hour ago
Aaron replied to Rainer Glaap's discussion 'Heartbleed, MITM - Security Issues'
"Thanks for bringing this up! As Rainer mentioned, Ning.com wasn't vulnerable to the Heartbleed…"
1 hour ago
Khatlen Guse replied to Stig Karlsen's discussion 'Problems with Facebook activity feed'
"Hi Stig! My feed its ok now! :) I hope that your is ok too."
2 hours ago
soaringeagle replied to Riccardo Rossini's discussion 'Please Ning staff'
"id use that but to be safe make sure theres no copywrite on the pentaprism and if there is it…"
2 hours ago
Riccardo Rossini replied to Riccardo Rossini's discussion 'Please Ning staff'
"I know very well SE, I ensure you that it was a sort of gratitude for the new platform for us. I…"
2 hours ago
Riccardo Rossini replied to Riccardo Rossini's discussion 'Please Ning staff'
"Phil. I take the occasion just to ask you if you took alook at this, for me ot could be e very good…"
3 hours ago

© 2014   Created by Ning.

Badges  |  Report an Issue  |  Terms of Service