Current status of the Ning Platform is always available on the Ning Status Blog.

NC for Hire

Embedding Youtube videos on your ning network is a terrific way to curate content which pertains to your site's subject matter.  But one problem that can arise will actually drive traffic back away from your network and that is when a member (or non-member) clicks ont he Youtube logo within a video which takes the visitor back to that video on Youtube.   Here is a hack that will remove the Youtube logo from the embed.

The following post contains two videos that are embedded straight from YouTube. They are essentially the same videos except that one of the embedded video players does not not carry any YouTube-specific branding. Take a look:

This video player has a YouTube logo in the control bar (bottom right)..

 

.. while the player embedded below carries no such logo.

 

 

Removing the YouTube Logo from the Video Player

If you would like to remove the logo from the YouTube player before embedding it on to your website, you need to make a minor change to the default embed code as outlined below.

For the IFRAME version:

<iframe width="500" height="300"
src="https://www.youtube.com/embed/abc?modestbranding=1"
frameborder="0" allowfullscreen>
</iframe>

For the old OBJECT version:

<object width="500" height="314"> <param name="movie"
value="https://www.youtube.com/v/abc?version=3&rel=0&modestbranding=1">
</param><param name="allowFullScreen" value="true"></param>
<param name="allowscriptaccess" value="always"></param>
<embed type="application/x-shockwave-flash" width="500" height="300"
src="https://www.youtube.com/v/abc?version=3&rel=0&modestbranding=1"
allowscriptaccess="always" allowfullscreen="true">
</embed>
</object>

 

 

Use the default embed code for a YouTube video and just add modestbranding=1 at the end of the video URL and the YouTube logo won’t show up in the Flash Player.

The new “modestbranding” parameter for YouTube is supported for both Flash-based and IFRAME based embed codes (that are HTML5 compatible).

Update: The previous version of this article used the “showinfo=0″ parameter with “modestbranding=1″ but for the video player to be completely logoless, the showinfo parameter needs to removed. Brian Glick from the YouTube team shares why:

The reason why the video “YouTube” logo overlay appears is because the modestbranding option normally, by itself, still shows some branding – in the form of a small “YouTube” text overlay in the upper-right corner of the video, when you hover over it while the video’s paused. But since you explicitly asked for showinfo=0, we have no place to show the “YouTube” text overlay. So the alternative is to communicate that it’s a YouTube video player via the video overlay.

Thanks to buddy Amit on Labnol for this awesome and useful tip!

You need to be a member of Ning Creators Social Network to add comments!

Join Ning Creators Social Network

Votes: 0
Email me when people reply –

Replies

  • Hah! Sweet bro! Thanks for the share.

    • NC for Hire

      yep...i put this up with you in mind specifically...

      • Indeed? Well I certainly appreciate the effort.

  • Thanks

  • Tip of the week!!!

    I was contemplating on placing videos on certain pages but I did not want any chance of my content to take viewers away from my site (mainly my online shop). Your tip was just what I needed!

    On these certain pages of mine, I also wanted to the video to play automatically. You do it with this code at the end -  &autoplay=1 so if you want both it works this way - &autoplay=1&modestbranding=1

    You can view one of them at Body Glove Surf Shop

  • For some reason it's not working for me this is the code I'm using


    <iframe width="853" height="480"
    src="https://www.youtube.com/embed/videoseries?list=PLF73955473D3D471D"&autoplay=1&modestbranding=1 frameborder="0" allowfullscreen>
    </iframe>

    this is the original code

    <iframe width="853" height="480" src="https://www.youtube.com/embed/videoseries?list=PLF73955473D3D471D" frameborder="0" allowfullscreen></iframe>

    can someone please help so I can get the logo off of the player also autoplay?

  • NC for Hire

    @C. Brickhouse

    Update: The previous version of this article used the “showinfo=0″ parameter with “modestbranding=1″ but for the video player to be completely logoless, the showinfo parameter needs to removed. Brian Glick from the YouTube team shares why:

    The reason why the video “YouTube” logo overlay appears is because the modestbranding option normally, by itself, still shows some branding – in the form of a small “YouTube” text overlay in the upper-right corner of the video, when you hover over it while the video’s paused. But since you explicitly asked for showinfo=0, we have no place to show the “YouTube” text overlay. So the alternative is to communicate that it’s a YouTube video player via the video overlay.

    For the IFRAME version:

    <iframe width="500" height="300"
    src="https://www.youtube.com/embed/abc?modestbranding=1"
    frameborder="0" allowfullscreen>
    </iframe>

    For the old Object Version:

This reply was deleted.
 

Some interesting articles related to community management, digital marketing etc. could be found in our digest. Don't hesitate to leave a feedback so we would know that we should continue :-)

Latest Activity

Myron Dewey updated their profile
16 hours ago
Bizz replied to Bizz's discussion
Tip: PROFILE THEMES
"Thanks buddy, yep moved onto the layouts now and have added page sizes now so users can choose how…"
yesterday
Annabel Gregory replied to Bizz's discussion
GETTING REALLY FRUSTRATED WITH THIS !!
"We are having the same problems here - also in the UK - we keep getting this pop-up"
yesterday
Bizz replied to kostasgr's discussion
RSS OFF..///--.ning_3...///
"Jfarrow has lot's of cool stuff for rss feeds etc, check him out as may be able to help"
Sunday
kostasgr replied to Bizz's discussion
GETTING REALLY FRUSTRATED WITH THIS !!
"Bizz ! .. we should all mention it .... and the internal RSS feeds do not work are all off ...and t…"
Sunday
Bizz replied to Bizz's discussion
GETTING REALLY FRUSTRATED WITH THIS !!
"Glad to see you added this to the forum as well so at least they know it's network wide and not jus…"
Sunday
kostasgr replied to kostasgr's discussion
RSS OFF..///--.ning_3...///

 
 
 
 
 
 
 
 
 
  
 
 
 "
Sunday
kostasgr replied to Bizz's discussion
GETTING REALLY FRUSTRATED WITH THIS !!
Sunday
kostasgr replied to Bizz's discussion
GETTING REALLY FRUSTRATED WITH THIS !!
"hi Bizz ..!!...And I have the same problem ... I have +++ and the RSS interiors do not work ... the…"
Sunday
Bizz posted a discussion
Whatever Ning has done or is doing is causing a lot of problems and it's getting really annoying. N…
Saturday
kostasgr posted a discussion
Hi !! ... does anyone know any code ?? Because they told me they did a renewal .. the ning ..and th…
Saturday
⚡JFarrow⌁ replied to Bizz's discussion
Tip: PROFILE THEMES
"great work Bizz... coming along nice!"
Friday
More…

Meanwhile, you can check our social media channels